As you may have heard from other SaaS provider, on April 7, 2014 the OpenSSL Project released an update to address a critical vulnerability known as Heartbleed (CVE-2014-0160). This vulnerability, which affects multiple sites across the Internet, could be remotely exploited to leak sensitive information.

I just wanted to ensure all our customers that e-conomic do not use OpenSSL in any of our infrastructure components. So there is no reason to be alarmed, your data is quite safe and it will not be necessary to change your passwords.

Best regards,

Director of Operations